常见问题解答

Q: 龙芯平台下64位系统chrome31是否支持中文输入功能.

A:chrome31在32位系统下和64位系统下都是支持中文输入功能的。
  chrome31在64位系统下是在版本10之后开始支持中文输入。

Q: 龙芯平台下64位系统chrome31是否支持打印文档功能.

A:chrome31在32位系统下和64位系统下都是支持打印功能的。
1)首先检查系统cups服务是否启动:service cups status; 如果未启动:service cups start.
2)chrome31在版本9及之后开始支持打印功能。
3)chrome31打印文档,依赖系统下32位mipsel gtk。gtk库需支持打印后端。/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so。
如果没有,可访问 http://ftp.loongnix.org/browser/chrome/31/fedora21/chrome31-31.0.0-10/gtk2.24-mipsel.tar.gz下载

Q: 龙芯平台下64位系统chrome31点击图标无法启动

A:chrome31在64位系统下需要32位库支持,而因系统多样性,所以会出现缺库的现象。
可以在命令行下执行:/opt/chrome31/chrome 看是否缺少哪些32位库,可以从源上安装32位库或者从32位系统下拷贝过来32位库安装到/opt/chrome31/lib目录。

Q: 龙芯平台下64位系统flash没有声音.

A: 由于64位系统下flash是利用nspluginwrapper包装32位flash而成。所以需要安装32位的依赖库。安装32位的alsa-libs即可解决

Q: 龙芯平台下webrtc功能,启用音频后浏览器出现崩溃现象.

A: 你可以从下面链接 找到对应系统的pulseaudio库,安装后就可以解决。  http://ftp.loongnix.org/browser/webrtc/o32/pulseaudio/

Q: 龙芯平台下浏览器是否支持flash打印?

A:龙芯平台下浏览器时支持flash打印功能的。
  1:首先需要确保龙芯机器能连上打印机并能打印文档
    1) 检查cups服务状态,确保在运行。命令行执行 service cups status; 如果出现cpusd is runnig 就可以。如果未运行,执行service cups start启动
    2) 然后:打开浏览器:地址栏输入127.0.0.1:631 添加打印机。登陆名和密码都是用户账号。
    以我连接的网络打印机【打印机型号M1213nf】为例:配置的打印机驱动为1913mfp。
    添加打印机结束后,可以点击打印测试页按钮,或者打印wps文档测试打印机。
  2:确保用户电脑已安装flash。
    安装参考链接:http://wiki.loongnix.org/index.php/FlashPlayer_32 
    如果客户flash页面无法打印,尝试打印下面的测试用例。http://www.primaryworksheets.co.uk/multiws/multi23.html

Q: 龙芯平台下chrome31的webgl是否支持?

A:需要做如下修改
    sudo cp /opt/chromium/chrome_sandbox /opt/chromium/chrome-sandobx
    sudo cp /opt/chromium/chrome-sandbox usr/local/sbin/chrome-devel-sandbox 
    sudo chown root:root /usr/local/sbin/chrome-devel-sandbox
    sudo chmod 4755 /usr/local/sbin/chrome-devel-sandbox
    export CHROME_DEVEL_SANDBOX=/usr/local/sbin/chrome-devel-sandbox1

Q: 龙芯平台下chrome31的显卡硬件加速功能是否支持?

A:由于浏览器在各个平台的兼容性问题,firefox浏览器默认不开启硬件加速功能。据目前测试,硬件加速功能目前在3A1000和3B处理器可用。用户可按照如下方式开启:
  1:在浏览器地址栏输入:Chrome://flags
  2:找到“对所有网页执行 GPU 合成 Mac, Windows, Linux”项,下拉选择“已停用”

Q: 龙芯平台下chrome31命令行下报错:ERROR:command_buffer_proxy_impl.cc(161)] Could not send GpuCommandBufferMsg_Initialize.

A: fedora13下mesa库的版本升级到9.2.5-5.20140916

Q: chrome浏览器 webrtc支持情况如何?

A:从chrome31-31.0.0-5.0版本,chrome31的Webrtc功能就开始支持。
   具体安装步骤见:http://wiki.loongnix.org/index.php/Webrtc_32
   具体的测试网站:
      Chrome:http://simpl.info/rtcpeerconnection/
             http://simpl.info/rtcdatachannel/
      Firefox: mozilla.github.io/webrtc-landing/pc_test.html

   如果您在测试过程中,发现无法进行视频通信:请按照以下流程操作:
      1)首先确保在系统中可以通过外接USB摄像头获取视频,具体利用linux平台下Cheese软件测试。
        如果USB摄像头无法获取视频,需查看系统是否安装gstreamer库,以及内核中是否支持USB Camera驱动。
      2)然后安装chrome31-31.0.0-5.0版本及以上,进行测试。   

Q: gstream库如何安装

A: 修改源:
   vim /etc/yum.repos.d/fedora.repo
   将baseurl修改为baseurl=http://loongnix.org/ftp/os/Fedora13-o32/RPMS
   yum search gstreamer

Q: 浏览器版本迭代比较快,用户该如何选择?

A: 我们建议您及时下载最新的浏览器,因为在版本迭代过程中会修复一些bug,以及对进行代码进行优化。

Q: 龙芯平台上chrome版本问题?

A: chrome31版本是我们将长期支持和维护的版本,我们会保持同步更新官方代码,同时在官方代码的基础上,我们会基于龙芯平台做出一系列优化和适配。例如我们已添加了MMX指令集优化,视频格式支持,延迟加载技术等。我们会定期集成官方优化代码和我们自己的优化成功,发布更新版本的浏览器,以提升用户体验。

Q: chrome浏览器有时候启动不起来?

A: 如果通过点击图标发现chrome浏览器无法正常启动,
   请通过命令行尝试启动来发现问题:/opt/chrome31/chrome。
   如果发现报错误:/dev/shm permission denied
   请执行以下命令修复:sudo chmod 1777 /dev/shm.
   如果还有其它问题,请反馈给我们。

Q: 在浏览一些页面时,发现flash插件加载不了?

A: 请从浏览器官方页面上下载flashplayer插件,并按照用户手册安装到指定目录。
   如果您还加载不了flash插件:请按照以下流程操作:
      在浏览器地址栏里输入about:config,并保证下面配置参数正确性
          dom.ipc.plugin.enabled true
          dom.ipc.plugins.unloadASAP true
          dom.ipc.plugins.flash.subprocess.crashreporter.enabled true
   最后,请重新启动浏览器,耐心等待会哦。

Q: 在播放flash视频时候,发现视频播放不流畅?

A: 如果您希望得到更流畅视频播放体验,可以使用我们提供的chrome浏览器,其内置flash转换成html5插件。您只需在浏览视频网站时,轻轻一点击右上角红色的html5图标,即可得到更流畅的用户体验。目前支持优酷,56等常见的视频网站。

Q: Feodra19上安装chrome31时如果出现依赖libxss.so.1安装不上?

A: sudo yum install libXScrnSaver.mipsel之后,重新安装即可。

Q: 系统上安装浏览器RPM包时出现库依赖,包安装不进去的问题怎么办?

A: 我们建议首先看看是哪个库装不进去,如果有相关知识的人你可以预先将缺少的库装入你的系统中。如果没有相关知识的,你就在安装RPM包时,添加--nodeps,忽略依赖库直接安装。

返回浏览器

本页面最后修改于2016年9月30日 (星期五) 10:45。

© 2017 by 龙芯开源社区 • Powered by MediaWiki