常见问题解答

Q: firefox浏览器的版本选择 (下面的答复只针对2016.11.11的版本状态)

1,firefox24、firefox40、firefox45这几个版本哪个的性能最好?

A:firefox45较firefox24 在js性能,html5等方面要好很多,但目前启动速度要比firefox24要差一点,正在优化。

2,firefox24、firefox40、firefox45这几个版本都能支持flash和WPS插件吗?

A:firefox24和firefox45都支持flash播放,但目前64位wps插件未开发,也就是暂且firefox45不支持wps插件,不过后期会有的。

3,对这几个版本的维护策略是什么?因为各个版本都有优缺点,比如firefox24对HTML5支持不好;firefox40、firefox45也会存在其他问题。

A:目前重点在优化firefox45的性能,包括启动速度,渲染效率,js跑分等。firefox24我们主要是对一些功能性的问题完善。在firefox45优化后,有适用于firefox24的部分我们也会porting到firefox24上
总体来说,ff24 要比45 稳定,而且在实际产品和项目中的使用量也是ff24更大。ff24是已经维护了几年的可靠产品。
但是如果一定追求最高性能,64位的ff45 性能要好,而且对html 5等新协议的支持更完善。
另外从长远来看,龙芯的桌面操作系统都将升级到64位。考虑未来的可持续性,ff45更有优势。

Q: firefox浏览器上设计模式designmode下不能显示弹出菜单

A:目前该功能在龙芯平台32位和64位浏览器均得到功能修正
32位版本:firefox-24.0.0-17版本及以后
64位版本:firefox-45.3.0-5版本及以后

Q: firefox浏览器上 pdf文件加载

A:在龙芯平台浏览器,目前对于 pdf文件加载支持如下两种方式:
1)浏览器默认方式:浏览器内嵌PDF.js,其能自动化支持打开pdf文件。其特点在于不需要安装其他类型插件,默认支持。
2)插件方式:龙芯平台支持mozplugger插件打开pdf文件方式。其特点在于:加速速度快。
测试网址:http://grs.pku.edu.cn/document/20160315095936596074.pdf

[mozplugger插件安装说明]

Q: firefox浏览器上 avi wmv mpg rmvb格式视频不能正常播放

A:在fedora13上,和中标麒麟系统上需要安装gecko-mediaplayer插件
  在deepin系统上,需要安装browser-plugin-vlc插件。

Q: 龙芯平台下64位系统flash没有声音.

A: 由于64位系统下flash是利用nspluginwrapper包装32位flash而成。所以需要安装32位的依赖库。安装32位的alsa-libs即可解决

Q: 龙芯平台下sqlite读取firefox历史数据库的问题.

A: 系统带的sqlite 版本号需要和浏览器中使用的版本号一致。firefox目前sqlite版本号是3.9.1

Q: 龙芯平台下webrtc功能,启用音频后浏览器出现崩溃现象.

A: 你可以从下面链接 找到对应系统的pulseaudio库,安装后就可以解决。 [[http://ftp.loongnix.org/browser/webrtc/o32/pulseaudio/|点我下载]] 

Q: 龙芯平台下浏览器是否支持flash打印?

A:龙芯平台下浏览器时支持flash打印功能的。
  1:首先需要确保龙芯机器能连上打印机并能打印文档
    1) 检查cups服务状态,确保在运行。命令行执行 service cups status; 如果出现cpusd is runnig 就可以。如果未运行,执行service cups start启动
    2) 然后:打开浏览器:地址栏输入127.0.0.1:631 添加打印机。登陆名和密码都是用户账号。
    以我连接的网络打印机【打印机型号M1213nf】为例:配置的打印机驱动为1913mfp。
    添加打印机结束后,可以点击打印测试页按钮,或者打印wps文档测试打印机。
  2:确保用户电脑已安装flash。
    安装参考链接:http://wiki.loongnix.org/index.php/FlashPlayer_32 
    如果客户flash页面无法打印,尝试打印下面的测试用例。http://www.primaryworksheets.co.uk/multiws/multi23.html

Q: Firefox40无法加载插件?

A: 请您将Firfox40的版本更新到firefox40-40.0.2-RC2版本及以上。因为我们在firefox40-40.0.2-RC2解决了无法加载插件的问题。而firefox40-40.0.1-RC1的确无法自动加载插件。

Q: Firefox24的Canvas性能介绍

A: 龙芯浏览器团队对浏览器后端skia库做了充分优化,其支持Canvas性能得到明显提升。
   用户可以通过在浏览器地址栏里输入about:config,并配置一下参数
        变量:gfx.canvas.azure.backends 值:skia,cairo
        变量:gfx.content.azure.backends 值:skia,cairo

Q: 龙芯平台下Firefox24的启动优化?

A:我们通过在系统中预留微进程,和利用linux多workspace特性,实现了浏览器秒起功能。<br>
但是由于在用户浏览器体验过程中,会因为插件加载,配置选项重新加载,页面开发,安全等问题,我们在版本12中关闭了秒起功能。用户如果想体验秒起版本,可点击尝试。
[http://www.loongnix.org/ftp/browser/firefox/24/NeoKylin/firefox24-24.0.0-11.ND6.mipsel.rpm 体验版]

Q: 龙芯平台下Firefox24的显卡硬件加速功能是否支持以及webgl功能优化?

A:由于浏览器在各个平台的兼容性问题,firefox浏览器默认不开启硬件加速功能。据目前测试,硬件加速功能目前在3A1000和3B处理器可用。用户可按照如下方式开启:
  1)在浏览器地址栏里输入about:config
  2) 添加以下变量设置:
  在浏览器地址栏里输入about:config,并保证下面配置参数正确性
        webgl.force-enabled true
        webgl.msaa-force true       
        layers.acceleration.force-enabled true
        gfx.direct2d.force-enabled true

   最后,请重新启动浏览器,耐心等待会哦。

Q: Firefox浏览器 webrtc支持情况如何?

A; 从firefox40-RC2版本,firefox的webrtc功能就开始支持。
   而且第二个版本默认支持vp8编解码;https://mozilla.github.io/webrtc-landing/pc_test.html
   第三个版本之后默认支持h264编解码:https://mozilla.github.io/webrtc-landing/pc_test_h264.html

Q: gstream库如何安装

A: 修改源:
   vim /etc/yum.repos.d/fedora.repo
   将baseurl修改为baseurl=http://loongnix.org/ftp/os/Fedora13-o32/RPMS
   yum search gstreamer

Q: 浏览器版本迭代比较快,用户该如何选择?

A: 我们建议您及时下载最新的浏览器,因为在版本迭代过程中会修复一些bug,以及对进行代码进行优化。

Q: 龙芯平台上firefox版本问题?

A: firefox24是mozilla官方的长期支持版本。我们会保持同步更新。在mozilla官方代码的基础上,我们会基于龙芯平台做出一系列优化和适配。例如我们已添加了javascript jit后端,插件运行的独立线程机制,profile工具等。我们会定期集成官方优化代码和我们自己的优化成功,发布更新版本的浏览器,以提升用户体验。

Q: 在浏览一些页面时,发现flash插件加载不了?

A: 请从浏览器官方页面上下载flashplayer插件,并按照用户手册安装到指定目录。
   如果您还加载不了flash插件:请按照以下流程操作:
      在浏览器地址栏里输入about:config,并保证下面配置参数正确性
          dom.ipc.plugin.enabled true
          dom.ipc.plugins.unloadASAP true
          dom.ipc.plugins.flash.subprocess.crashreporter.enabled true
   最后,请重新启动浏览器,耐心等待会哦。

Q: 在播放flash视频时候,发现视频播放不流畅?

A: 如果您希望得到更流畅视频播放体验,可以使用我们提供的chrome浏览器,其内置flash转换成html5插件。您只需在浏览视频网站时,轻轻一点击右上角红色的html5图标,即可得到更流畅的用户体验。目前支持优酷,56等常见的视频网站。

Q: 在firefox24上wps插件无法正常使用?

A:针对这一问题,可以依照以下步骤去解决
   1:请您检查你当前使用的firefox24是否已经及时更新至最新的版本;
   2:请参照wps插件使用说明正常安装了wps;
   3:拖拽wps.html测试页面到浏览器,测试其是否能正常使用;
      如果不能正常使用,请按照如下步骤对浏览器进行设置:
      1)在浏览器地址栏输入about:config; 进入参数设置界面后
      2)进入参数设置界面后,修改变量dom.ipc.plugin.enable为false
      重新刷新demo测试页即可。

Q: 系统上安装浏览器RPM包时出现库依赖,包安装不进去的问题怎么办?

A: 我们建议首先看看是哪个库装不进去,如果有相关知识的人你可以预先将缺少的库装入你的系统中。如果没有相关知识的,你就在安装RPM包时,添加--nodeps,忽略依赖库直接安装。

返回浏览器

本页面最后修改于2016年11月25日 (星期五) 17:09。

© 2017 by 龙芯开源社区 • Powered by MediaWiki